• Announcements

    • Scorchie™

      Upgrade   07/22/2016

      Welcome to Version 4.  You will need to log back in with your Display Name and/or Email Address.  If you don't know this, please issue a password or account reset to obtain the details you need. Some posts will appear "broken" (links, quote text, et al).  The forum is rebuilding all content which will take some time to complete.  Once this is done, the "missing" posts should also hopefully reappear. Should you encounter problems and wish to discuss, please post here:  

Archived

This topic is now archived and is closed to further replies.

Flumpf.

Having Problems Selecting Hdmi Inputs Directly On A Bravia When Programming Harmony Remotes?

11 posts in this topic

Hi all,

I picked up a $49 Xbox Harmony recently, and had a few issues pairing it with my shiny new 40W Bravia, in that it wouldn't change to HDMI inputs properly.

A few days of dilligent help from Logitech's email support team was very much appreciated, however they still couldn't fix the problem, emdinmg up resorting to a series of button presses that was just cumbersome.

Frustrated, I searched around the forums here today and found many refs to Sony owners having similar problems due to an apparent lack of discrete codes for HDMI. I didn't stumble across any posts that had solved the issue.

So, my curiosity got the better of me, and I sat down with the remote in device mode for the TV, trying all the functions Logitech think the TV has until lobbing on the codes that actually work. :)

HDMI1 = input video 6

HDMI2 = input video 7

I just reassigned the Sony HDMI inputs listed in the Harmony software to point to these, loaded the update into my Harmony and, to quote Elzar, "BAM!", evevrything works fine!

Anyway, I'm just posting in the spirit of helping, apologies if this has been brought up and solved before. There are a LOT of posts on this site to wade through! ;)

Cheers!

amyf.

0

Share this post


Link to post
Share on other sites

The old K.I.S.S. theory. I have been trying to pass this message on any new Harmony users for a while now. Logitech doesn't always name their commands the same as the original remote/hardware eg HDMI 1 on the Panasonic PX600 is "AVS DVI" :blink:

With any new user or newly added equipment, I suggest running through every command for each piece of hardware in "Device" mode on the Harmony and noting down what each command does. Thenremap any wrong commands or "learn" any new commands from the original remote, update the remote, check these codes work as they should, then add devices to "Activities".

0

Share this post


Link to post
Share on other sites

Generally the inputs are in the same order but named sequentially in the Harmony list. ie.

Composite (& S-vid) 1, 2, etc (depending on model)

Component 1, 2, etc (depending on model)

HDMI 1, 2, etc (depending on model)

VGA.

For example the 52X2000 has 3 composite, 3 component, 2 HDMI and VGA numbered sequentially inputs 1 - 9 on the Harmony software

0

Share this post


Link to post
Share on other sites

I tried and failed to get direct switching for HDMI input on my X series Bravia (pre 1080p model). Maybe they have updated the Sony codes and I should try again, but I gave up and just did a two step: DVD then Next Input.

Glad you got it working, I just got new gear so need to see if I can get it to work as HDMI is my main input now.

0

Share this post


Link to post
Share on other sites
Hi all,

I picked up a $49 Xbox Harmony recently, and had a few issues pairing it with my shiny new 40W Bravia, in that it wouldn't change to HDMI inputs properly.

A few days of dilligent help from Logitech's email support team was very much appreciated, however they still couldn't fix the problem, emdinmg up resorting to a series of button presses that was just cumbersome.

Frustrated, I searched around the forums here today and found many refs to Sony owners having similar problems due to an apparent lack of discrete codes for HDMI. I didn't stumble across any posts that had solved the issue.

So, my curiosity got the better of me, and I sat down with the remote in device mode for the TV, trying all the functions Logitech think the TV has until lobbing on the codes that actually work. :)

HDMI1 = input video 6

HDMI2 = input video 7

I just reassigned the Sony HDMI inputs listed in the Harmony software to point to these, loaded the update into my Harmony and, to quote Elzar, "BAM!", evevrything works fine!

Anyway, I'm just posting in the spirit of helping, apologies if this has been brought up and solved before. There are a LOT of posts on this site to wade through! ;)

Cheers!

amyf.

Can you list the steps you took to get this to work as I have the same setup and am getting confused from logitechs software.

0

Share this post


Link to post
Share on other sites
Can you list the steps you took to get this to work as I have the same setup and am getting confused from logitechs software.

Apologies for the late response, I don't check all threads all the time.

Here's what you do...

- Select the 'devices' tab in the Harmony software.

- In the TV box click the 'settings' on-screen button

- Select 'adjust inputs'

- page 1: select method 2

- page 2: review input list - this should echo the inputs on your TV

- page 3: select remote buttons. Just choose the correct settings for HDMI1 etc and continue through the section until it's done.

Hoping that helped. :)

Cheers!

amyf.

0

Share this post


Link to post
Share on other sites

Hey can you tell me the model number from your Bravia amyf?

I'm trying to set up my 32" V series. The inputs in the Harmony software are all labelled correctly (e.g. "Input HDMI 1"), but the HDMI ones won't work. Thought it might be worth setting it up like yours and trying the "Input Video 6" trick.

0

Share this post


Link to post
Share on other sites
Hey can you tell me the model number from your Bravia amyf?

I'm trying to set up my 32" V series. The inputs in the Harmony software are all labelled correctly (e.g. "Input HDMI 1"), but the HDMI ones won't work. Thought it might be worth setting it up like yours and trying the "Input Video 6" trick.

Sounds to me like it is not mapped right in the Logitech DB. Turn your TV on and in "device" mode go thropugh each command and note what each does. Then you should be able to find it and map it correctly.

0

Share this post


Link to post
Share on other sites
Hey can you tell me the model number from your Bravia amyf?

I'm trying to set up my 32" V series. The inputs in the Harmony software are all labelled correctly (e.g. "Input HDMI 1"), but the HDMI ones won't work. Thought it might be worth setting it up like yours and trying the "Input Video 6" trick.

Im having the same issue with my 32D3100, I tried using device mode to access the HDMI ports and to my frustration I can only get composite, s-video, component and RGB inputs to work as discrete codes! :(

0

Share this post


Link to post
Share on other sites

Ok In the end I settled for

Method 3: Select this method if your TV is a Samsung, or if you press a button to bring up an on-screen menu of source inputs, press a different button to cycle between them, and press a third button to accept the selection.

and told the remote how to access the menu etc etc and then set the Inter-key & input-delays to 100ms. B)

0

Share this post


Link to post
Share on other sites
Ok In the end I settled for

Method 3: Select this method if your TV is a Samsung, or if you press a button to bring up an on-screen menu of source inputs, press a different button to cycle between them, and press a third button to accept the selection.

and told the remote how to access the menu etc etc and then set the Inter-key & input-delays to 100ms. B)

Sorry for reviving an old thread.

but i thought one of you guys might know..

Is there any way to get the channel list on these TVs?

I generally go to menu and then digital channels.

I made a macro to press menu-down-select, but I think there might be a better way.

0

Share this post


Link to post
Share on other sites