Jump to content


Photo

Xms Sdx-250p - Hard Drive Issues


  • Please log in to reply
79 replies to this topic

#51 diesel

diesel

    AV Forums Member

  • Senior Member
  • 13,782 posts

Posted 09 April 2009 - 09:04 AM

Thanks for the tip on a replacement. Is it getting good reviews? Or few bad ones?

The Toppy 5000 has been the benchmark for many years. This newer model adds HDMI output, but still maintains the status as one of the best (if not the best) SD PVRs on the market

#52 wabster

wabster

    AV Forums Member

  • Member
  • 15 posts

Posted 09 April 2009 - 02:25 PM

The Toppy 5000 has been the benchmark for many years. This newer model adds HDMI output, but still maintains the status as one of the best (if not the best) SD PVRs on the market


Thanks Diesel I've been referred to the local rep/service centre to get a Return Auth for repair under warranty.

I'll go through that process and see what happens. But I've bookmarked the Topfield on DSE's site for future use.

Cheerz Wabster

#53 wabster

wabster

    AV Forums Member

  • Member
  • 15 posts

Posted 19 April 2009 - 10:14 AM

Just an open request to both winjohnson (post 15 on this thread) and jok11n regarding the SDX-250P. As I said in my post above, my device is currently with the repair people at Sylvania.

The problems I have experienced, and those of many others on reading this thread, indicate a probability that the WD HDDs are the root cause of the problems.

Are the repairers likely to put a new Hitachi HDD (as mentioned by winjohnson) into the system, rather than another WD? Additionally will they by default upgrade any firmware etc that may need doing, without my specifically requesting it?

Obviously I am keeping a log of what is happening in case we need to take the issue further when I get the device back, thanks for any comments you might have on this. I did try to contact you both via PM but it seems I don't have the right to send them at present.

Cheerz Wabster

#54 jokiin

jokiin

    AV Forums Member

  • Senior Member
  • 3,560 posts

Posted 19 April 2009 - 10:41 AM

Just an open request to both winjohnson (post 15 on this thread) and jok11n regarding the SDX-250P. As I said in my post above, my device is currently with the repair people at Sylvania.

The problems I have experienced, and those of many others on reading this thread, indicate a probability that the WD HDDs are the root cause of the problems.

Are the repairers likely to put a new Hitachi HDD (as mentioned by winjohnson) into the system, rather than another WD? Additionally will they by default upgrade any firmware etc that may need doing, without my specifically requesting it?

Obviously I am keeping a log of what is happening in case we need to take the issue further when I get the device back, thanks for any comments you might have on this. I did try to contact you both via PM but it seems I don't have the right to send them at present.

Cheerz Wabster


yes there was a batch of these with faulty hard drives, even if they replace with the same brand and model it wouldn't be from the same batch so unlikely you would have this problem again, faulty drives can happen in any brand so don't get hung up too much about the brand, if they replace the drive then the problems should be resolved

as to the firmware I doubt they would do it by default as they are unlikely to know it exists, they might do it if you prompt them otherwise you will need a serial cable to do it yourself, the last firmware fixed the problem with consecutive timer recordings

#55 Rupert

Rupert

    AV Forums Member

  • New Member
  • 2 posts

Posted 20 April 2009 - 10:26 AM

Well at least I'm not alone. Having the "O" mb drive problem. Strathfield store closed. XMS support tel no disconnected.
Where to now?
Have got receipt but beginning to think it's not worth the paper it's written on.
Anybody had any luck?
Thanks

#56 Rupert

Rupert

    AV Forums Member

  • New Member
  • 2 posts

Posted 20 April 2009 - 10:30 AM

hello guys,

We are the manufacturer of this product whick located in China, to be frankly,the PVR may have HDD problem,we now going to return back the defective units to factory repaird. we have sold many PVR to Aus market but only XMS-250P have this problem,it is west digital HDD, we now have changed our HDD supplier to Hitachi. I think it will be better.


Hi winjohnson. Am having the problems (well documented in this forum). Can you advise what I can do do. the unit was bought from Strathfield and still under warranty. Thanks in advance.

#57 GottyNF

GottyNF

    AV Forums Member

  • Member
  • 6 posts

Posted 20 April 2009 - 12:12 PM

I bought one of these units from deals direct and have a different problem
this is what i have found for other readers
my PVR did not show a disk so I opened it up and found the disk was not even connected but is happy now! (plug it in)
as for the pin I tried for some time and could not crack it UNTIL I realised "made in china"
AHA lucky Chinese number 8 so tried 6 x 8 and viola success pin = 888888 :rolleyes:
the pin does not do much for you really!
but that does not help me I need a firmware upgrade/change it seems
coming from Norfolk Island we run the international standard so need a European type firmware (8 megabit bandwidth)
so if any of you guys know where to get the correct firmware for xms sdx-250p (unmask Australia) it would be appreciated muchly!
:D

#58 GottyNF

GottyNF

    AV Forums Member

  • Member
  • 6 posts

Posted 20 April 2009 - 12:15 PM

I bought one of these units from deals direct and have a different problem
this is what i have found for other readers
my PVR did not show a disk so I opened it up and found the disk was not even connected but is happy now! (plug it in)
as for the pin I tried for some time and could not crack it UNTIL I realised "made in china"
AHA lucky Chinese number 8 so tried 6 x 8 and viola success pin = 888888 :rolleyes:
the pin does not do much for you really!
but that does not help me I need a firmware upgrade/change it seems
coming from Norfolk Island we run the international standard so need a European type firmware (8 megabit bandwidth)
so if any of you guys know where to get the correct firmware for xms sdx-250p (unmask Australia) it would be appreciated muchly!
:D

#59 GottyNF

GottyNF

    AV Forums Member

  • Member
  • 6 posts

Posted 20 April 2009 - 12:20 PM

whoops haveing trouble with posting takes 10 mins to get results and then have 4 copies!

Edited by GottyNF, 20 April 2009 - 12:26 PM.


#60 GottyNF

GottyNF

    AV Forums Member

  • Member
  • 6 posts

Posted 20 April 2009 - 12:20 PM

I bought one of these units from deals direct and have a different problem
this is what i have found for other readers
my PVR did not show a disk so I opened it up and found the disk was not even connected but is happy now! (plug it in)
as for the pin I tried for some time and could not crack it UNTIL I realised "made in china"
AHA lucky Chinese number 8 so tried 6 x 8 and viola success pin = 888888 :rolleyes:
the pin does not do much for you really!
but that does not help me I need a firmware upgrade/change it seems
coming from Norfolk Island we run the international standard so need a European type firmware (8 megabit bandwidth)
so if any of you guys know where to get the correct firmware for xms sdx-250p (unmask Australia) it would be appreciated muchly!
:D

#61 GottyNF

GottyNF

    AV Forums Member

  • Member
  • 6 posts

Posted 20 April 2009 - 12:23 PM

I bought one of these units from deals direct and have a different problem
this is what i have found for other readers
my PVR did not show a disk so I opened it up and found the disk was not even connected but is happy now! (plug it in)
as for the pin I tried for some time and could not crack it UNTIL I realised "made in china"
AHA lucky Chinese number 8 so tried 6 x 8 and viola success pin = 888888 :rolleyes:
the pin does not do much for you really!
but that does not help me I need a firmware upgrade/change it seems
coming from Norfolk Island we run the international standard so need a European type firmware (8 megabit bandwidth)
so if any of you guys know where to get the correct firmware for xms sdx-250p (unmask Australia) it would be appreciated muchly!
:D

#62 wabster

wabster

    AV Forums Member

  • Member
  • 15 posts

Posted 22 April 2009 - 10:16 PM

I just want to update my experience for the community on the issues I had with my XMS SDX-250.

Deals Direct referred me to a repairer, who I then contacted. They emailed me a Return Authorisation doc for the repair which I completed then sent, and received in a day or two a Return Auth.

As the repairer was in Sylvania, about 20 minutes drive away I elected to take the machine in a box with paperwork to them which I did on the 14th of April. I was contacted afternoon on the 20th and told the machine was ready, that the hard drive was the problem, had been replaced, and that it was all fixed.

I collected it yesterday the 21st and it seems to be working fine. However as there is still 6 months on the warranty, I have all the copies of the documentation in the box. It pays to be organised :-)

But I've got to say the guy at the repairer seemed friendly and helpful and really positive that the thing will work well now the HDD problems is resolved.

Cheerz Wabster.

#63 GottyNF

GottyNF

    AV Forums Member

  • Member
  • 6 posts

Posted 23 April 2009 - 11:19 AM

does any one have contact info for the repairer I need info/firmware to change to 8 MHertz bandwidth
if so send to alans at ni dot net dot nf
I need to remove/change the mask program for mainland Australia to international standards!
they have mask programmed it to be friendly on the mainland but not here on the island!

#64 wabster

wabster

    AV Forums Member

  • Member
  • 15 posts

Posted 23 April 2009 - 11:41 AM

does any one have contact info for the repairer I need info/firmware to change to 8 MHertz bandwidth
if so send to alans at ni dot net dot nf
I need to remove/change the mask program for mainland Australia to international standards!
they have mask programmed it to be friendly on the mainland but not here on the island!


Gotty in message number 15 in this thread winjohnson indicates that he works for the manufacturers of this product.

As you have now more than 5 posts I think you can PM him and he may be able to help you.

I didn't ask my repairers about firmware upgrades. You may have to get Dealsdirect to give you a "return auth" or something that authorises the repairers to talk to you.

FWIW the email for the repairers I used is support@lbau.com.au

Cheerz Wabster

#65 humpy

humpy

    AV Forums Member

  • Member
  • 6 posts

Posted 24 July 2009 - 07:40 PM

have just sent your details off, sorry it wasn't sooner but I never got a PM which would have emailed me a notification :)



Hi
Could I also pls have the info needed for updating the firmware..

email william aat cybersol.com.au ..

many thanks

#66 Dizzie

Dizzie

    AV Forums Member

  • New Member
  • 3 posts

Posted 24 August 2009 - 03:35 PM

Hi,
Has anyone else had (or heard of?) issues with the XMS SDX-250P stb? It's the one Strathfield were selling (possibly still are) earlier in the year for $250, the one with the 250GB hard drive. I'm onto my 2nd one of these, the first one went back within 6 weeks when the hard drive died, it wouldn't even reformat. Six months later the replacement one is acting up as well, where it doesn't seem to realise there's a hard drive there....sometimes if I power it off at the back and leave it for a bit I can get it to recongnise the hard drive, but most of the time it doesn't make any difference. I've a few things on there I still want to try and watch, so I'm reluctant to try formatting at this stage....

Cheers!

Good day,
Yes I have one and I have had it repaired twice through the Highland Service Centre try going to support@lbau.com.au or phone 1300 850 350 mine was repaired under warranty so you could try but I not sure about out off warranty went mine broke down I first tried the XMS Service number 1300 662 029 then I sent an email to support@xmsdigital.com.au no reply so I contacted direct the company I bought it from this was dealsdirect they were the ones that gave they gave myself the Highlander Service Centre number and email address so try going to Strathfield Car Radios and see what they say.

#67 Dark Star

Dark Star

    AV Forums Member

  • New Member
  • 1 posts

Posted 20 October 2009 - 03:10 PM

Hi,
Has anyone else had (or heard of?) issues with the XMS SDX-250P stb? It's the one Strathfield were selling (possibly still are) earlier in the year for $250, the one with the 250GB hard drive. I'm onto my 2nd one of these, the first one went back within 6 weeks when the hard drive died, it wouldn't even reformat. Six months later the replacement one is acting up as well, where it doesn't seem to realise there's a hard drive there....sometimes if I power it off at the back and leave it for a bit I can get it to recongnise the hard drive, but most of the time it doesn't make any difference. I've a few things on there I still want to try and watch, so I'm reluctant to try formatting at this stage....

Cheers!


I bought 2 of these units in late 2008 and lost 2 hard drives in succession over a few months in one of them. The other I gave away to a relative who did not use it much because of unspecified problems. As I am a electronics hobbyist I decided to see what was inside the box and found a problem on the power supply board in May 2009. The two large value electrolytics at the LV end (3300uf I think) were all leaking a brown fluid. I replaced them plus the 450V 33uf capacitor, which was also leaking. I suspect that the capacitors may have part of a dodgy batch and any voltage spike on turn on/off may have got thru and fried the HDD. Since then it has worked - till this week, when the display LED and clock would just turn off after half an hour. The remote worked fine and the front buttons worked, but the display was blank. All voltages in the unit were ok but there was brown fluid on the PC board on the front panel and some of the screws holding it in place were really rusty. I cleaned it up and all works ok - for now. I hope this helps because the unit is really simple to use and the wife does not want to replace it. Hope this helps.

I wouldn't mind a new driver if anyone has one...
-_-

#68 rsha12

rsha12

    AV Forums Member

  • Member
  • 5 posts

Posted 22 January 2010 - 11:32 AM

I'm having the same hard drive issue (XMS SDX-250P was fine for first 16 months)
Can anyone help?

#69 rsha12

rsha12

    AV Forums Member

  • Member
  • 5 posts

Posted 22 January 2010 - 11:35 AM

jok11n, can you please PM me? I'd like some help in getting a quote on repairing the XMS SDX-250P

#70 rsha12

rsha12

    AV Forums Member

  • Member
  • 5 posts

Posted 22 January 2010 - 11:37 AM

More info: mine was actually damaged by an electricity outage (hard drive will not boot since power went out and came back up)
Without a quote to repair I doubt I can place a claim for them to repair or replace the PVR

#71 rsha12

rsha12

    AV Forums Member

  • Member
  • 5 posts

Posted 22 January 2010 - 11:40 AM

I have now called Highland Service Centre, waiting for a call back.

#72 rsha12

rsha12

    AV Forums Member

  • Member
  • 5 posts

Posted 22 January 2010 - 11:41 AM

XMS service number appears to be disconnected. Any other options in Melbourne?

#73 tiggy

tiggy

    AV Forums Member

  • New Member
  • 1 posts

Posted 11 April 2010 - 09:32 AM

In response to all of the above - I bought my XMS 250P SDX at Strathfield Adelaide in Nov 2008. During 2009 I had many of the same problems as listed in the posts above- the playback would not happen even though there was a program there. Sometimes it would not record at a set time. I found that by enabling the time shift function that problem went away [don't know why]. But now the machine has died completely. The Strathfield store in Adelaide has closed - I was put through to the Noarlunga store, miles away from where I live. Anyway it was out of warranty, but I still wanted to get it fixed. I took it to a local electronics guy who was optimistic he could resurrect it, and ordered a part - the power supply had burned out. He also said it had leaking capacitors. After he got another power supply unit, he tried to get it going, but it would not work- he said the motherboard had died, and he could not get another one. There were lots of programs I recorded on the hard drive - is there any way to retrieve them ? It doesn't have a USB input.

#74 sutex

sutex

    AV Forums Member

  • New Member
  • 1 posts

Posted 28 April 2010 - 07:52 PM

Hi,
Has anyone else had (or heard of?) issues with the XMS SDX-250P stb? It's the one Strathfield were selling (possibly still are) earlier in the year for $250, the one with the 250GB hard drive. I'm onto my 2nd one of these, the first one went back within 6 weeks when the hard drive died, it wouldn't even reformat. Six months later the replacement one is acting up as well, where it doesn't seem to realise there's a hard drive there....sometimes if I power it off at the back and leave it for a bit I can get it to recongnise the hard drive, but most of the time it doesn't make any difference. I've a few things on there I still want to try and watch, so I'm reluctant to try formatting at this stage....

Cheers!


I removed and changed the hard dive no problems

#75 Aibs

Aibs

    AV Forums Member

  • Member
  • 8 posts

Posted 01 June 2010 - 10:56 PM

I want to know restrictions too.