Jump to content


Photo

Lg 52sz8r Dlp Rptv - Owner's Report 12 Months On


  • Please log in to reply
207 replies to this topic

#176 qonyx

qonyx

    AV Forum Member

  • New Member
  • 1 posts

Posted 25 November 2009 - 07:44 PM

Hi All,

First of all - want to say that this is fantastic thread on the LG DLP. It is interesting to read so many responses and get some good technical perspective on how to replace the lamp.

Anyway I'm about to purchase my first lamp replacement @ 7900 hours and came across the following website

http://www.bluestar-...CFQEwpAoduBmoog

Does anyone know if it is the Square or Round lamp that I should be replacing?

The price is good @ 115USD (and even better ATM with a favorable exchange rate) so for those folks interested in stocking up then this could be a good option.

Thanks again for everyone's contribution that has made this a great knowledge base. Anyway look forward to reading a response.

Regards,
Qonyx :D

#177 Dork(original)

Dork(original)

    AV Forum Member

  • Senior Member
  • 3,678 posts

Posted 08 February 2010 - 04:17 PM

Tucka,
afaik this TV is rock solid.Apart from the globe i can't fault it.
Paul.

Whoops i spoke to soon.It won't turn on now.
The power light just flashes yellow then turns off.
Any ideas?Off to the repair shop we go.
Paul.

#178 Alfred Smee

Alfred Smee

    AV Forum Member

  • Member
  • PipPipPip
  • 435 posts

Posted 08 February 2010 - 05:16 PM

Hi All,

First of all - want to say that this is fantastic thread on the LG DLP. It is interesting to read so many responses and get some good technical perspective on how to replace the lamp.

Anyway I'm about to purchase my first lamp replacement @ 7900 hours and came across the following website

http://www.bluestar-...CFQEwpAoduBmoog

Does anyone know if it is the Square or Round lamp that I should be replacing?

The price is good @ 115USD (and even better ATM with a favorable exchange rate) so for those folks interested in stocking up then this could be a good option.

Thanks again for everyone's contribution that has made this a great knowledge base. Anyway look forward to reading a response.

Regards,
Qonyx :D


The part number for the lamp you require is 6912B22007B and it looks just like the one pictured at the link you provided.

Edited by DrKildare, 08 February 2010 - 05:18 PM.


#179 Dork(original)

Dork(original)

    AV Forum Member

  • Senior Member
  • 3,678 posts

Posted 09 February 2010 - 04:35 PM

Well i have organised the set to go to the shop.
They are thinking colour wheel ATM.
They spoke with LG in Sydney and they have four left.
They will not be ordering anymore,so if your colour wheel goes get in quick.
Paul :o

#180 Dork(original)

Dork(original)

    AV Forum Member

  • Senior Member
  • 3,678 posts

Posted 17 February 2010 - 06:32 PM

How spooky is this.
I was working at Woodlands golf course today and there on a table is
my TV(same model you know what i mean),not being used.
The manager says it's on Ebay.
Sure enough it is.They want $800 for it link.
Paul.

#181 Addyhash

Addyhash

    AV Forum Member

  • New Member
  • 2 posts

Posted 06 March 2010 - 09:30 AM

Hi Guys,

Very impressive thread, I would like to thank everyone who posted constructivly to this thread over last 3 years, geat info!!!

My globe warning started popping up only this week, had set a good 4-5 years or so , great picture through playstation 3 running on 1080i
never used analog tuner, always run through component 1 with Topfield pvr.

Total globe hours: 7931 and still going... ( touch wood ) although have noticed that picture not as bright lately.

I too found it hard to access globe hour menu, ok on tv and mute on remote for 'exactly' 5 secs seems to be the trick.

thanks for recommending drtv in towoomba, still the best quote for bulb, have ordered, but will wait till bulb dies before replacing.

Keep up the good work

Addyhash.

#182 DrVY

DrVY

    AV Forum Member

  • New Member
  • 2 posts

Posted 09 March 2010 - 10:39 PM

Whoops i spoke to soon.It won't turn on now.
The power light just flashes yellow then turns off.
Any ideas?Off to the repair shop we go.
Paul.



I have the same problem last week and had my set for more than 4 years now. Still have extended warranty but they said globe not cover under warranty and need to transport to service centre before they can look at it. Can anyone tell me when globe completely blown will the "globe indicator light" still will lit up red when turn tv on? Mine just same as describe by Paul the power light flashes yellow and turn off to standby mode. without any other indicator light come on but I notice a few day prior to that, the image is a bit darker than normal but without any message come up and said anything about the globe on screen. Any help will be great help since if its not cover by warranty I will need to pay for the transport fees to service centre.

#183 DrVY

DrVY

    AV Forum Member

  • New Member
  • 2 posts

Posted 09 March 2010 - 10:39 PM

Whoops i spoke to soon.It won't turn on now.
The power light just flashes yellow then turns off.
Any ideas?Off to the repair shop we go.
Paul.



I have the same problem last week and had my set for more than 4 years now. Still have extended warranty but they said globe not cover under warranty and need to transport to service centre before they can look at it. Can anyone tell me when globe completely blown will the "globe indicator light" still will lit up red when turn tv on? Mine just same as describe by Paul the power light flashes yellow and turn off to standby mode. without any other indicator light come on but I notice a few day prior to that, the image is a bit darker than normal but without any message come up and said anything about the globe on screen. Any help will be great help since if its not cover by warranty I will need to pay for the transport fees to service centre.

#184 Tunners

Tunners

    AV Forum Member

  • New Member
  • 1 posts

Posted 10 March 2010 - 09:47 AM

Sorry! I'm a newbie to this forum and I can't find the right place to ask my question - so I'm asking it here.

I bought an Avatec LCD TV about 2 years ago, and have just busted the remote.

I checked on the net to find where I could get another remote, and all I found was Avatec's non functioning website. I can find no retail outlets or comment forums on Avatec, nor any news about the company, either.

Please: does anyone know what happened to Avatec? Have they gone bust? Will I never be able to buy a new remote for my Avatec LCDAC-TD320F8? :huh:

#185 bugs1357

bugs1357

    AV Forum Member

  • New Member
  • 4 posts

Posted 08 April 2010 - 01:10 PM

I've had my LG 52SZ8R-TB since 1 Sep 2005.
Since then I have got over 20,000 hours from two lamps.
Replaced original lamp in Aug 2007, cost AU$230 from SEQ Electronics in QLD.
Second one is just about to go (TV switching off and lamp light flashing).
What a fantastic run from a very resonably priced TV at the time (paid $2497 in 2005).

#186 lightning_jack_au

lightning_jack_au

    AV Forum Member

  • New Member
  • 3 posts

Posted 16 May 2010 - 01:43 AM

Hi Everyone :)

I need your help people!!! lol

I scored one of the TVs last week for free( Lg 52sz8r-TB)
The lamp has been replaced and i'm pretty sure Ive reset the lamp hour counter(Grey box top r-hand side of screen with clock?)

Searched the net and found the (menu/menu) (menu/mute) instructions, did what that said , etc,

It now shows 00:00

The problem is, when I turn the TV on, it still shows the Lamp Life Over MSG at start up for around 1 min, every time.

The service menu says nothing about the lamp or resetting the timer etc,, (Menu/Menu on remote)

When I press the OK/Mute on remote, the grey box shows on the top right hand side with a clock showing 00:00 but still the Lamp Life Over Msg appears on start up still???

What am i doing wrong?? I dont have a manual for this TV, never owned any LG stuff before either etc..

Do i need to purchase the LG service remote that has more access to the TV to fix this problem>>(LG MKJ40653801)

Any help is appreciated !!!!!!!!!!!!!!!!!!!!!!!!!!

#187 lightning_jack_au

lightning_jack_au

    AV Forum Member

  • New Member
  • 3 posts

Posted 25 May 2010 - 09:56 PM

Finally, after 4 weeks of scratching my head, I worked it out lol.

You have to hold the OK on the TV, and the Mute on the remote for a fairly long time.

Mine takes an average of 13 seconds or longer before the lamp timer comes up for reset.

I was giving up after about 7 secs,,, etc...

Thats all it was.

:)

#188 lightning_jack_au

lightning_jack_au

    AV Forum Member

  • New Member
  • 3 posts

Posted 25 May 2010 - 09:57 PM

All the other posts say for 5 seconds lol,

No wonder I couldnt get it to work lmao

#189 John2230

John2230

    AV Forum Member

  • Member
  • 12 posts

Posted 18 August 2010 - 12:20 AM

Well my 52sz8r-tb appears to have called it a day. It has about 28,000 hours on it & has developed a temperature problem that I've not been able to resolve. The current lamp has 5400 hours and still works well.

TheTV will be working fine & at any time from 10 minutes to about 5 hours after turning on, the temp lamp will flash 3 - 5 times & the set will turn itself off. There is very little mention of this issue anywhere & most of what I did find was rubbish. There were two helpful threads that discussed the problem & discussed cleaning & replacing fans.

What a great idea ..... checking & cleaning the fan behind the lamp box is easy - very accessible, not much cleaning required & it's working well.

The second fan is another story. It's completely inaccessible, mounted on the connector side of a bundle of components which includes the SUB ENGINE ASSY, AL C/W SUPPORTER(WITH HEAT SINK & some sort of power transformer, it can be seen (sort of) by removing the access panel in the rear center of the set. But to reach it you'd need the forearm of a 9 year old boy (or a very petite female ), I don't have the assistance of either one.

It appears that the only way to check, clean & if necessary replace this fan, is to disassemble the whole set. I hear some of you saying 'Have a go you got nothing to lose'. Well pulling it apart & reassembly doesn't phase me but the prospect of realigning mirrors, light tunnel etc .... I have the service manual - it's not particularly helpful.

The Fans are available from the LG parts distributor in South Australia for $35 each plus postage. It seems there are two variants of the 52SZ8R-TB, AMILLA and AAULLSK-LGEAP. In the 52SZ8R-TB.AMILLA the two fans are identical - LG part number: 5900V09008F. The 52SZ8R-TB.AAULLSK-LGEAP uses the 5900V09008F behind the lamp box but the inaccessible one is 5900V09008E.

Any info or advice is most welcome. Mean time I hope this is helpful to someone else with the temperature light problem.

Cheers

John

#190 John2230

John2230

    AV Forum Member

  • Member
  • 12 posts

Posted 18 August 2010 - 12:30 AM

Forgot to mention, needing a TV while the old one is indisposed, I turned to eBay & picked up another 52SZ8R-TB (needing a lamp replacement) & used the lamp from my old set.

#191 John2230

John2230

    AV Forum Member

  • Member
  • 12 posts

Posted 18 August 2010 - 04:38 PM

WhaHoo! Bargain

Look what I just found on eBay . Since that item will expire, the seller is lamps-4-less here's the link to his listings. With the Aussie dollar doing so well against the pound It comes out at about $120 inc free postage.

I checked out his website where he has over 300 rear projection lamps listed. Then I rang him (voip of-course). These are the Belgium globes, manufactured under licence from Philips by Osram Belgium. I've read raves about the high quality of these lamps compared to the 'made in China' ones we get here.

The cheapest I could find a bulb locally was $187. I'm a tight fisted character at the best of times so I clicked the button & bought the Belgium Osram for $120.

It's coming from Glasgow & the guy reckons about 2 weeks for delivery - I'll let you know how it goes.

Cheers
J.

#192 Dork(original)

Dork(original)

    AV Forum Member

  • Senior Member
  • 3,678 posts

Posted 22 August 2010 - 11:05 AM

John well done.
I bit the bullet and got a globe from the last place i bought one $187 plus postage from Qld.
After being told the colour wheel is dying and it wouldn't be as bright as it should be.
It's now in the bedroom.
When it dies to the tip in a million bits it goes :(
It has been a good tv.
Paul.

#193 firthy69

firthy69

    AV Forum Member

  • Member
  • 11 posts

Posted 14 September 2010 - 04:06 PM

WhaHoo! Bargain

Look what I just found on eBay . Since that item will expire, the seller is lamps-4-less here's the link to his listings. With the Aussie dollar doing so well against the pound It comes out at about $120 inc free postage.


Thanks for the link John, Just replaced mine from there, quick postage from Scotland, got here in 10days.
Just a note, the globe on the site says model 52SZ8R-ZA but they will work on 52SZ8R-TB models...
Wrapt my colours are bright again, just in time for the Grand Final.
I dont know the excact hours this last globe did as the set went back for repairs about 6 times, so Im unsure if its the same globe as they tried everything to get it working again. But since the last time it was reset it had 5500 total hrs on it which is rubbish as my first globe did over 10k hrs...Ive reset it and see how this one goes...
Not a bad price also, $102aud delivered ....
GBP 59.00
AU $97.97
Buy it Now

Edited by firthy69, 14 September 2010 - 04:12 PM.


#194 firthy69

firthy69

    AV Forum Member

  • Member
  • 11 posts

Posted 23 July 2011 - 10:57 PM

Well it finally died today and has been replaced with a Sony Bravia LED LCD set...rest in peace...

#195 John2230

John2230

    AV Forum Member

  • Member
  • 12 posts

Posted 10 January 2012 - 02:45 AM

Globe update. Beginning of November I bought another globe from the same ebay guy in Scotland - cost $81 inc. postage

My second set is running well & with the old one in the garage for spares it will be quite a while before I pension it off. So I thought I'd best get another globe to be ready for the inevitable.

I keep seeing the new sets getting cheaper with more features & the prices still get even cheaper. And while my old 52SZ8R is still performing well, I'm saving buckets as the new prices continue to fall even further.

#196 Juzzo

Juzzo

    AV Forum Member

  • New Member
  • 1 posts

Posted 09 February 2012 - 08:45 AM

Hi Guys,
I was sitting watching my unit on the weekend (52SZ8R-TB) when I heard a loud bang from inside the box, instantly the screen lost its colour. No image quality was lost, its just black and white, actually more like sepia.

Would this be the colour wheel retiring? It sounded like a spinning item self destructing, I've noticed they are about $160, seems reasonable. Its removing and installing that particular component thats got me worried, is it worth it? It appears to have some level of complexity regarding filters, mirrors and calibration etc.. Has anyone changed one over before, or got any tips (other than taking it there :)

Still has the original lamp from 2006. The red lamp light has also just come up. Although the image is still very bright, I will replace, but only if the colour wheel is the other problem and viable to replace.

regards, Juzzo.

#197 Dork(original)

Dork(original)

    AV Forum Member

  • Senior Member
  • 3,678 posts

Posted 18 February 2012 - 02:49 PM

John well done.
I bit the bullet and got a globe from the last place i bought one $187 plus postage from Qld.
After being told the colour wheel is dying and it wouldn't be as bright as it should be.
It's now in the bedroom.
When it dies to the tip in a million bits it goes style_emoticons/default/sad.gif
It has been a good tv.
Paul.


Boy is this TV one great buy.Still running.
It must be at least eight years old now.
Paul

#198 Alfred Smee

Alfred Smee

    AV Forum Member

  • Member
  • PipPipPip
  • 435 posts

Posted 10 March 2012 - 08:47 AM

Boy is this TV one great buy.Still running.
It must be at least eight years old now.
Paul


Yeah gotta agree. 4000 hours on third lamp and PQ is exactly the same as when bought mid 2005.

#199 Dork(original)

Dork(original)

    AV Forum Member

  • Senior Member
  • 3,678 posts

Posted 25 September 2012 - 07:04 PM

Still working like a treat.
I dragged it outside last Saturday night to watch the Hawks and for a BBQ(we cooked the meat on the BBQ,not the TV) :hyper: and my 52nd birthday.
We played some music BD's and had the sound flat out up to 100.(just the TV speakers)
Not one bit of distortion.
:queen: Paul.

Edited by Mr craptastic, 25 September 2012 - 07:09 PM.


#200 Alfred Smee

Alfred Smee

    AV Forum Member

  • Member
  • PipPipPip
  • 435 posts

Posted 20 November 2012 - 03:31 PM

Put third lamp in my TV today. It has done nearly 25000 hours and is over 7 years old. It still works just like new but I wouldn't say no to a new LED TV ;-)

Edited by Alfred Smee, 20 November 2012 - 03:32 PM.