Jump to content


Photo

Topfield Tf7100Hd Plus Copy Problem


  • Please log in to reply
7 replies to this topic

#1 narly

narly

    AV Forum Member

  • Member
  • 12 posts

Posted 09 April 2012 - 06:10 PM

Hi , I have a Topfield TF7100HD Plus and copy some programs that I have recorded to an external drive via the USB. However I can't copy anything I record on SBS , I just get a " failed to open file message ". The file / program is ok as I can view it on the toppy.

#2 mikeathome

mikeathome

    AV Forum Member

  • Member
  • PipPipPip
  • 297 posts

Posted 11 April 2012 - 03:41 PM

This is caused by there being an illegal Windows character in the file name. It is not always a visible character. You may be able to get rid of it by renaming the file on the 7100+ - backspace right to and past the beginning of the file name and then type in whatever you wish to call the file. If this doesn't work you could FTP the file to a PC using an FTP program that will remove/replace the illegal Windows character.

#3 narly

narly

    AV Forum Member

  • Member
  • 12 posts

Posted 11 April 2012 - 05:15 PM

Thanks for your reply , I'll give it a try

#4 prl

prl

    AV Forum Member

  • Senior Member
  • 2,634 posts

Posted 11 April 2012 - 06:27 PM

SBS (sometimes?) puts a 0x05 character (ASCII ENQ control character) at the beginning of program titles in the FTA EIT EPG, and if the title is used as-is to create a Windows file name, it can cause problems. This problem on the Topfield 7100 was mentioned in the Beyonwiz beta forum (by a beta tester who has both BW & Topfield recorders) as far back as June 2009 (no link, sorry, because it's in a beta testers only part of the forum). There's no such problem in the IceTV guide. I don't know about the Freeview EPG - but that's not going to be an issue on the 7100 anyway.

I'm not sure when Beyonwiz firmware fixed the problem for new recordings from SBS, but in Jan 2011 the 01.0x.350 firmwareadded a feature (under WizPnP enhancements in the release notes) to allow the removal of the control characters from existing recording names.

Discussion on the Beyonwiz forum suggests that historically SBS isn't the only broadcaster to have done something like this: Nine apparently used to put a 0x01 (ASCII SOH) at the beginning of titles.

Edited by prl, 11 April 2012 - 06:29 PM.


#5 narly

narly

    AV Forum Member

  • Member
  • 12 posts

Posted 12 April 2012 - 04:44 PM

That's whats happenning prl . I can rename the file on the toppy but the character is still there when transferred , It won't allow me to rename it either. Don't know if Topfield did a fix or not .

#6 prl

prl

    AV Forum Member

  • Senior Member
  • 2,634 posts

Posted 12 April 2012 - 05:33 PM

That's whats happenning prl . I can rename the file on the toppy but the character is still there when transferred , It won't allow me to rename it either. Don't know if Topfield did a fix or not .

Hi, narly. Have you tried what mikeathome suggested? That is, I think, on the Topfield go to rename the recording, delete the name character by character until all the name has gone, then press the "delete character" button one more time (to delete the control character that's not being displayed). Then enter the new name for the recording. The workaround on the Beyonwiz was like his, too.

#7 narly

narly

    AV Forum Member

  • Member
  • 12 posts

Posted 13 April 2012 - 04:09 PM

I've tried what mikeathome suggested without success . I'm not familiar with FTP programs and how they work , but might give them a try anyway .

#8 mikeathome

mikeathome

    AV Forum Member

  • Member
  • PipPipPip
  • 297 posts

Posted 15 April 2012 - 09:02 AM

Yes, the rename method does not always work unfortunately. Try using an FTP program (such as Filezilla) running on your PC if your PVR is networked - its free and reasonably easy to use and it will remove the illegal character automatically. There are other options that use Topfield TAPs - I suggest you go to the Topfield forum for advice on using them.